Issue with Compose Services


I am having trouble with running Gen3 using compose-services locally. The first time I ran the services after following the setup instructions things worked fine. I could login in with my google account and use the data portal with no disconnects / crashes.

However, when I tried to run the services a second time (a day later after composing down) nothing would show up on localhost. I did a clean install, and after trying to startup multiple times I only got it to load once but it was buggy. I attempted another clean install but things don't seem to be working.

Here is a link to the zip from the script


Hi @Zander_Giuffrida! Welcome to the forum!

Thanks for providing your dump. Are you using Docker Desktop? I'm asking because our developers mentioned a very similar problem was caused by Docker Desktop settings: it was set to make 4 CPUs available to the Docker Engine, and start working after limiting it to 1 CPU in Docker > Preferences > Advanced. Here is the relevant log from logs-esproxy-service.txt:

[36mesproxy-service      |[0m ERROR: [1] bootstrap checks failed
[36mesproxy-service      |[0m [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[36mesproxy-service      |[0m [2020-01-16T13:59:32,475][INFO ][o.e.n.Node               ] [cogtRnY] stopping ...
[36mesproxy-service      |[0m [2020-01-16T13:59:32,937][INFO ][o.e.n.Node               ] [cogtRnY] stopped
[36mesproxy-service      |[0m [2020-01-16T13:59:32,938][INFO ][o.e.n.Node               ] [cogtRnY] closing ...
[36mesproxy-service      |[0m [2020-01-16T13:59:33,030][INFO ][o.e.n.Node               ] [cogtRnY] closed

Hi @Viktorija ,

No I'm not using Docker Desktop. I'm running Docker on Ubuntu.

I closed all the other applications on my computer and was able to get the portal to work. I monitored the memory usage of the services and noticed that their memory usage was climbing slowly over time. It went from 1.5gb initially to 5gb and then started filling my swap.

The spark-service was logging this line:

spark-service | Re-format filesystem in Storage Directory root= /hadoop/hdfs/data/dfs/namenode; location= null ? (Y or N) Invalid input:

Hi @Zander_Giuffrida,

Thanks for this information, I'm glad you got your portal back again! I'll try to find out what's going on and will let you know my findings.

Hi Zander!

We reproduced the issue you are running into and created a story to fix it. Thank you! I will let you know the progress.

1 Like

Hey @Viktorija could you send me an invite to the slack channel? Thanks!

We sent you an invite @Zander_Giuffrida :slight_smile:

Hi @Zander_Giuffrida!

Our developers suggest to run this command before starting Compose Services:

sudo sysctl -w vm.max_map_count=262144

This would help to start esproxy-service. Could you try this and let me know the result?

Hey @Viktorija,

Yes that seems to be working. I'll let you know if I run into any other issues.



1 Like

Hello @Viktorija,

I've been trying to get data upload to work on my local gen3 installation, and ran into some issues similar to what's described in this post:

I added the self-signed certificate to trusted certificates on my OS (Ubuntu). After a few tries I was able to configure a profile using the following command:
gen3-client configure --profile=zander --cred=~/compose-services/credentials.json --apiendpoint=https://localhost

When I run
gen3-client auth --profile=zander
it returns:
Screenshot from 2020-02-04 13-42-17

However, when I run
gen3-client upload --profile=zander --upload-path=~/Documents/text.txt
I get the following error:

Could you help me resolve this issue?



File submission is not fully working in Compose Services, but it should not give you Internal Server Error. Could you share your logs?

Also I wonder if you are able to create program/project in your commons like described here