Trying to create a Gen3 Development machine in AWS

I am trying to create a Gen3 development environment (Gen3 on Helm) in AWS using this guide: gen3-helm/gen3ForDevs/ at doc/gen3Setup · uc-cdis/gen3-helm · GitHub

Although I've created this Ubuntu server in a variety of ways (WorkSpace, EC2, ...) I always end up in the same place when trying to install rancher-desktop: Nested virtualization not enabled on this host.

After reading What is KVM? - Kernel-Based Virtual Machine Explained - AWS, I even tried using an Amazon Linux instance but received this same error. Is there any hope for running the Gen3 Helm development machine in AWS?


Hello, BDR!

I think you also posted in our Gen3 Community slack (for visibility for other readers of this post, anyone can request joining our Gen3 Community Slack channel by completing this form). To help other see the response you got on the Slack, I'm reposting it here.

Rancher desktop is one way of running kubernetes on your node.If you have docker running on any host, you can use kubernetes-in-docker f.ex to start your kubernetes cluster. Then, after you have KIND running, and you can verify that you can run kubectl get pods or other kubectl commands, you can follow the rest of the documentation to set up your values.yaml and install with helm.

-- Sara