Error when downloading with gen3-client

Edit: Resolved!

I would really appreciate any insight about how to resolve an error I get trying to download GTEx data from using gen3-client?
I was downloading a manifest of about 15,000 junction count files, and after successfully downloading 960, I started getting an error

Got a non-200 or non-206 response when doing GET req for URL associated with GUID dg.ANV0/(...) HTTP status code for response: 400

It happens now no matter what file I try, and using the download-multiple command or the download-single. It's been a few weeks since I first got the error, and I've tried downloading from different computers/locations.
Any ideas what the issue could be, or how to fix it? Or alternatively, another way to download the GTEx data?


Figured it out!
I was missing the --protocol=s3 flag, specifying which bucket it should download from. I'm not sure why it worked for the first 960 files though, but I'm glad its working now. (And it is downloading much faster than it was without that flag).